Startseite · Forum · CAN Module · Shops · Preisliste · Katalog · Pressearchiv · Downloads · Videos · WebLinksDienstag, 22. Oktober 2019
Thema ansehen
 Das CAN digital Bahn Projekt > Steuerungssoftware
 ModellStellwerk
Vorheriges Thema Nächstes Thema

Seite 3 von 3 < 1 2 3
search
Thread Startpost: Blockproblem on
Autor RE: Blockproblem   21 # 24 top
Ulli9391
Spezialist




Beiträge: 561

Eingetreten: 06.01.12
Status: Offline
Eingetragen am 05.10.2019 17:37  

Hallo,

zu 'iftraintype' habe ich Versuche gemacht.

1 setcontact(32, 1)
2 iftraintype(6, 14, 4)
3 goto(7)
4 pause(1)
5 setcontact(32, 0)
6 route(36, on)
7 end

Mit diesem Makro hat es funktioniert.
setcontact(32, 0/1) ist nur zur Kontrolle
Im Block (6) wird getestet ob das ein Lokzug ist (14),
wenn nicht -> Ende
wenn ja wird eine Fahrstraße gestellt.

Mehr kann man nicht erwarten.
Makro muss eingeschaltet sein, Fahrplan und Autozug hat keinen Einfluss.
Ist der SSB/aSB eingeschaltet, dann hat das Makro Priorität.

Gruß Ulli

 
Autor RE: Blockproblem   22 # 24 top
HeinzM
Amateur




Beiträge: 25

Ort: Windeck
Eingetreten: 29.05.18
Status: Offline
Eingetragen am 05.10.2019 22:41  

Hallo Ulli,

darf ich fragen, mit welcher Version ModellStw du dieses Makro mit iftraintype getestet hast?
Mit Version 9.7 oder 9.8.2 funktioniert es jedenfalls nicht.

Freundliche Grüße
Heinz


Modellstellwerk Vers 9.7, Windows 10, Lenz LZV100 V3.6, H0, DCC, LDT High Speed Interface

 
Autor RE: Blockproblem   23 # 24 top
Ulli9391
Spezialist




Beiträge: 561

Eingetreten: 06.01.12
Status: Offline
Eingetragen am 06.10.2019 11:17  

Hallo Heinz,

fragen darf man immer, wir sind ja auch deswegen hier.

Ich habe 9.8.2 installiert - und es geht.

Da Windows alle Befehle nur nacheinander abarbeiten kann,
kann es schon mal vorkommen, dass ein Befehl untergeht.
Und 99% - die DB wäre glücklich

Gruß Ulli

 
Autor RE: Blockproblem   24 # 24 top
0stefu0
Spezialist



Threadstarter

Beiträge: 96

Eingetreten: 06.06.13
Status: Offline
Eingetragen am 06.10.2019 17:09  

Hallo

Kleiner Zwischenbericht: Ich habe den Tipp von Heinz mit nur einem Melder und Haltmelder in cm ausprobiert und siehe da, es funktioniert. Es braucht bei den Loks noch kleine Anpassungen aber so weit bin ich zufrieden. Daurch habe ich jetzt noch ein par Melder "gewonnen" wo ich jetzt anderwertig verbauen kann

Zu gegebener Zeit werde ich mich auch wieder mit den Makros beschäftigen. Dies ist eine recht Komplexe "Steuerung".

Vielen Dank


Freundlicher Gruss aus Bern
Stefan
H0 DC, RocolineGleise
Steuerung: ECoS und Modellstw, DCC
Rückmeldung: Littfinski RM
Weichen: Switchpilot Servo

 
Seite 3 von 3 < 1 2 3
Springe zu Forum:
Copyright 2010 by Sven "DJeaY" Schapmann