Startseite · Forum · CAN Module · Shops · Preisliste · Katalog · Pressearchiv · Downloads · Videos · WebLinksFreitag, 24. Mai 2019
Thema ansehen
 Das CAN digital Bahn Projekt > M(ärklin)-CAN Module
 CC-Schnitte
Vorheriges Thema Nächstes Thema

 
Autor CC-Schnitte u. rocrail / Kommunikationsprobleme?   1 # 4 top
lukiafi
Amateur




Beiträge: 10

Eingetreten: 15.07.16
Status: Offline
Eingetragen am 05.05.2019 17:02  

Hallo zusammen,

ich habe seit einigen Jahren die CC-Schnitte 2.1 und betreibe sie an der Gleisbox am PC im Multiprotokollmodus (also mm2 und dcc) mit rocrail unter der Zentrale mcs2, Win 10, 64 bit. Da rocrail jetzt die Zentrale mcs2 nicht mehr unterstützt und durch mbus ersetzt hat, ist jetzt wieder ein Problem aufgetaucht dass ich vor ca. 2 Jahren mal gepostet habe und so halb gelöst wurde.
Das alte Problem: Wenn die Schnitte mit USB am Rechner hängt und ich rocrail starte und die Loks einlese (also die Spannung einschalte) werden zwar alle eingelesen, aber viele DCC-Fahrzeuge kann rocrail nicht über ihre Adresse ansprechen. Rocrail merkt das nicht und gibt alle Befehle, aber physisch bewegt sich das Fahrzeug nicht (tritt bei verschiedenen Decodern auf und liegt offenbar nicht daran). Wenn ich dann in der Loktabelle die Schnittstelle von DCC auf Motorola ändere (alle meine DCC Loks haben Multiptotokoll-Decoder, fahren aber auf DCC) kann ich die Lok nter mm2 bewegen. Da mir das nicht gefiel hatte ich rausgefunden, dass ich erst Rocrail starten muss, die Loks einlesen und dann die Spannung ausschalten (System Stop). Dann erst hänge ich die Schnitte an den PC und schalte die Spannung wieder an. Statt "System Go" sagt rocrail nun "CS Go" und die Sache funktioniert. Das ging seit Jahren gut. Unter der Zentrale mbus liest rocrail allerdings die Loks nicht mehr ein, wenn die Schnitte nicht am PC hängt, d. h. der Workaround funktioniert nicht mehr :-(. Also muss ich sie vorher dranhängen. Und siehe da: Das alte Problem taucht wieder auf. Ein Umstieg auf mbus mit Schnitte ist daher nicht möglich.
Fährt jemand von euch auch in diesem Setup und kennt das Problem? Wäre schön wenn ihr mir hier helfen könntet. Es muss irgendetwas mit der Kommunikation Schnitte/Gleisbox/rocrail im Multiprotokollmodus zu tun haben.

Vielen Dank schon mal im voraus!

Grüße
Achim

 
Autor RE: CC-Schnitte u. rocrail / Kommunikationsprobleme?   2 # 4 top
Stephan
Spezialist


User Avatar



Beiträge: 415

Ort: 34246 Vellmar
Eingetreten: 30.11.10
Status: Offline
Eingetragen am 05.05.2019 21:34  

Hallo Achim,

ich kann Dir zwar nicht direkt helfen, aber:

- Dein Problem, DCC-Loks irgendwie nicht steuern zu können, habe ich nie gehabt (ich nehme die mgbox-Zentrale, die extra für die Gleisbox erstellt wurde), egal wie rum ich was eingeschaltet habe.
- Wer zwingt Dich zur neueren Version? In der Version-Historie kannst Du gucken, wann die mcs2 und die mgbox rausgeflogen sind. Probier ein Downgrade.

Ich gucke mir die neue mbus-Zentrale die Tage mal vorsichtig an, die Versions-Historie zeigt aber, dass da noch kräftig dran gedreht wird.

Gruß Stephan


3-Leiter-Spielbahner, baue gerade eine neue Anlage: C-Gleis, Rocrail, CC-Schnitte + Gleisbox zum reinen Fahren, PC-Schnitte + Gleisreporter zum Melden, Intellibox zum Schalten und für alles andere. Gleisbox + 6 Delta-Booster mit TAMS Boosterlink für volle MFX-Unterstützung auf der ganzen Anlage, Intellibox + Delta-Booster für Weichen etc.

 
Autor RE: CC-Schnitte u. rocrail / Kommunikationsprobleme?   3 # 4 top
lukiafi
Amateur



Threadstarter

Beiträge: 10

Eingetreten: 15.07.16
Status: Offline
Eingetragen am 05.05.2019 22:10  

Hallo Stephan,

danke für die schnelle Antwort. Ich weiß dass ich mit dem Problem ziemlich alleine bin :-(. Vielleicht ersuche ich es auch mal wieder im rocrail Forum damit. Ich habe natürlich auch noch eine Version mit mcs2 - und werde nun auch mal mgbox probieren. Das ist aber zu 90% die gleiche Zentrale wie mcs2 so daß ich mir hier nicht viel erhoffe.
Ich bin auf mbus umgestiegen, da dort auch der Zubehör besserr erkannt wird. Habe begonnen jetzt mit Weichendecodern. Die kann ich mit rocrail unter mcs2 z. B. nicht programmieren. Unter mbus geht es gut. Das hatte Rob so empfohlen.
Aber es stimmt - ich glaube an mbus wird noch heftig geschraubt so dass man erst mal abwarten sollte.

LG
Achim

 
Autor RE: CC-Schnitte u. rocrail / Kommunikationsprobleme?   4 # 4 top
Victor
Spezialist




Beiträge: 48

Eingetreten: 09.12.14
Status: Offline
Eingetragen am 10.05.2019 16:32  

Servus Achim,

ich benutze die Rocrailversion für Mojave(MAC) und habe seit der MBUS-Umstellung keine Probleme mit DCC. Vielleicht hast Du die Loks falsch konfiguriert. Vorher benutzte ich wie Stephan die mgbox, welche ebenfalls funktionierte, allerdings musste hier das Sendetiming der 13 Bytes auf 17ms korrigiert werden, welche jetzt wahrscheinlich bei mbus durch Anwahl der cc-Schnitte bereits durchgeführt wird.
Was mit mbus nicht funktionierte war die Rückmeldung des Weichenchefs, ob die Weiche die Endlage erreicht hat. Dies wurde jedoch nach Nachfrage im Forum wieder eingeführt und eingepflegt. Allerdings passiert wie Stephan beschreibt momentan sehr viel mit der mbus-Zentrale. Ich würde Dir empfehlen auf einer älteren mcs2 oder mgbox Zentrale zu fahren und von Zeit zu Zeit testen oben dann mit mbus geht.
Schau Dir aber lieber nochmals Deine Konfiguration an und ob auch in der Gleisbox alle Protokolle benutzt werden (mm, dcc, Mfx)
Grüße Victor


C-Gleis; CC-Schnitte mit Rocrail (MAC) und MS2; benötige noch keinen Booster, obwohl manchmal bis zu zehn Loks gleichzeitig fahren !


Bearbeitet von Victor am 10.05.2019 16:33
 
 
Springe zu Forum:
Copyright 2010 by Sven "DJeaY" Schapmann